Zercurity data services
  • Summary
  • Applications (7)
  • Packages (0)
  • Vulnerabilities (2)

linux-tools-4.10.0-35

Hashes
Linux kernel version specific tools for version 4.10.0-35 This package provides the architecture dependant parts for kernel version locked tools (such as perf and x86_energy_perf_policy) for version 4.10.0-35 on 64 bit x86. You probably want to install linux-tools-4.10.0-35-<flavour>.
  • SHA256: 887a42ee79c566cf2861fb33edeffd6af86a7160f57de41ab5bf5b93caa73d8d
  • SHA1: de34438fdaaeb5a5d5fd91141545a89613c2b11d
  • MD5: c8c59715c5357fbc0d17c7ffcfd37cd8
Information
  • Version: 4.10.0-35.39
  • Filename: linux-tools-4.10.0-35_4.10.0-35.39_amd64.deb
  • Size: 4733
  • Type: DEB
  • Source: linux
  • Architecture: AMD64
  • Owner: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
  • Dependencies: binutils (>= 2.28), binutils (<< 2.29), libaudit1 (>= 1:2.2.1), libc6 (>= 2.14), libdw1 (>= 0.157), libelf1 (>= 0.144), liblzma5 (>= 5.1.1alpha+20120614), libpci3 (>= 1:3.3.1-1), libslang2 (>= 2.2.4), libudev1 (>= 183), libunwind8, zlib1g (>= 1:1.1.4), linux-tools-common

Applications

NameTypeArchSizeRisk
libcpupower.so.4.10.0-35
/usr/lib/libcpupower.so.4.10.0-35
227040
usbip
/usr/lib/linux-tools-4.10.0-35/usbip
675440
turbostat
/usr/lib/linux-tools-4.10.0-35/turbostat
769040
cpupower
/usr/lib/linux-tools-4.10.0-35/cpupower
752240
perf
/usr/lib/linux-tools-4.10.0-35/perf
42916400
usbipd
/usr/lib/linux-tools-4.10.0-35/usbipd
554400
x86_energy_perf_policy
/usr/lib/linux-tools-4.10.0-35/x86_energy_perf_policy
101200

Vulnerabilities

NameRiskSourceFixed
CVE-2017-100025566USN
linux-cloud-tools-common
4.10.0-37.41
CVE-2017-1410655USN
linux-cloud-tools-common
4.10.0-37.41

Raw Object

{
  "sha256": "887a42ee79c566cf2861fb33edeffd6af86a7160f57de41ab5bf5b93caa73d8d",
  "sha1": "de34438fdaaeb5a5d5fd91141545a89613c2b11d",
  "md5": "c8c59715c5357fbc0d17c7ffcfd37cd8",
  "type": "DEB",
  "arch": "AMD64",
  "name": "linux-tools-4.10.0-35",
  "filename": "linux-tools-4.10.0-35_4.10.0-35.39_amd64.deb",
  "size": 4733,
  "description": "Linux kernel version specific tools for version 4.10.0-35\nThis package provides the architecture dependant parts for kernel\nversion locked tools (such as perf and x86_energy_perf_policy) for\nversion 4.10.0-35 on\n64 bit x86.\nYou probably want to install linux-tools-4.10.0-35-<flavour>.",
  "url": null,
  "version": "4.10.0-35.39",
  "source": "linux",
  "owner": "Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>",
  "dependencies": "binutils (>= 2.28), binutils (<< 2.29), libaudit1 (>= 1:2.2.1), libc6 (>= 2.14), libdw1 (>= 0.157), libelf1 (>= 0.144), liblzma5 (>= 5.1.1alpha+20120614), libpci3 (>= 1:3.3.1-1), libslang2 (>= 2.2.4), libudev1 (>= 183), libunwind8, zlib1g (>= 1:1.1.4), linux-tools-common",
  "applications": [
    {
      "path": "/usr/lib/libcpupower.so.4.10.0-35",
      "sha256": "ca6bed2ccee161a4955477b1f0778f37f8ac9853d0a2e603e3a104124285e3b2",
      "sha1": "86b1583adc84ceede5d189e7aa95363c8847e1d4",
      "md5": "0c200a66a36873613d9039b89c8d9029",
      "name": "libcpupower.so.4.10.0-35",
      "size": 22704,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/usbip",
      "sha256": "4920b91b98510c9867852d1dcaa889f90a7452a2d801e5494f2f28066f9827be",
      "sha1": "ae55249d13e0fa4d33cca287c6e1bab3b2532373",
      "md5": "a51dd6d2a7e31c20a0d1f9f563115c7b",
      "name": "usbip",
      "size": 67544,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/turbostat",
      "sha256": "c2d2611d054949debb51fc8c83e5295129da087abc89d07f7b6fbaa252494013",
      "sha1": "e1e83e6cbf767ef42ec264afc6113ee6e1b85a33",
      "md5": "66bfcec4def2812d64dd741579a05216",
      "name": "turbostat",
      "size": 76904,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/cpupower",
      "sha256": "a0c25cba264a4a83c42f047dbdaf0cb657e79779ce30b9ab239863ffb880433f",
      "sha1": "b2b54bec2aa16608d23738b647ca03be86e797ac",
      "md5": "9d8df190d0f77d2adbb9837d70221997",
      "name": "cpupower",
      "size": 75224,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/perf",
      "sha256": "f0cf028f3f06b8dcb917c4d3d0608b0296068561a2c8a11c41007fa2b88a01ca",
      "sha1": "b52285a568cc04bc12c2c4e3a07a2fc7a004f35d",
      "md5": "4b4aeed503787abda4a755c51155f680",
      "name": "perf",
      "size": 4291640,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/usbipd",
      "sha256": "e4e7f80196a47224756f0bf1f1bd2aefc03864e11a2259758e1c229b9069ea03",
      "sha1": "4d5cb515c71d13aca81870a0b4d31a6398ad6e7b",
      "md5": "9a964dc6b7f03ed4ed36af2d8b934894",
      "name": "usbipd",
      "size": 55440,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    },
    {
      "path": "/usr/lib/linux-tools-4.10.0-35/x86_energy_perf_policy",
      "sha256": "a1fde5179508a97ea6c72561f62cb4cb79256e246a713e669a2272ecd2c7f0ab",
      "sha1": "1c4992116acdbf8abbfff29880a9c785d12e65df",
      "md5": "7001c77386c24a5fcacab770a9b1c854",
      "name": "x86_energy_perf_policy",
      "size": 10120,
      "description": null,
      "package": 2826037,
      "platform": "LINUX",
      "risk": 0,
      "vulnerable": null,
      "outdated": null,
      "malicious": null,
      "created_at": "2021-03-23T04:33:59+00:00",
      "updated_at": "2021-03-23T04:33:59+00:00",
      "deleted_at": null
    }
  ],
  "vulnerabilities": [
    {
      "name": "CVE-2017-1000255",
      "risk": 66,
      "source": "USN",
      "sid": null,
      "fixed": {
        "sha256": "fe4bb5a4ec6909915c82bd28e060912a5f5b73ef8f0aa48b9a930d9b29bbbe08",
        "name": "linux-cloud-tools-common",
        "version": "4.10.0-37.41",
        "filename": "linux-cloud-tools-common_4.10.0-37.41_all.deb"
      },
      "created_at": "2021-04-06T17:33:26+00:00",
      "updated_at": "2021-06-29T22:58:55+00:00"
    },
    {
      "name": "CVE-2017-14106",
      "risk": 55,
      "source": "USN",
      "sid": null,
      "fixed": {
        "sha256": "fe4bb5a4ec6909915c82bd28e060912a5f5b73ef8f0aa48b9a930d9b29bbbe08",
        "name": "linux-cloud-tools-common",
        "version": "4.10.0-37.41",
        "filename": "linux-cloud-tools-common_4.10.0-37.41_all.deb"
      },
      "created_at": "2021-04-06T19:01:46+00:00",
      "updated_at": "2021-06-30T04:40:49+00:00"
    }
  ],
  "risk": 66,
  "vulnerable": 66,
  "outdated": 0,
  "malicious": 0,
  "created_at": "2017-09-13T13:02:11+00:00",
  "updated_at": "2021-03-23T04:33:59+00:00",
  "deleted_at": null
}